? ? 文章

Firefox将迎来大型变革:插件需提交审核

很快Firefox又要迎来一次巨大的升级,本次更新需要插件开发者对插件进行修改,这样才能继续在新版Firefox上运行。以后Firefox 将采用了新的插件API,名叫WebExtensions,和Chrome与Opera的系统类似,这样跨多个浏览器进行插件开发也就容易多了。

Firefox将迎来大型变革:插件需提交审核

开发者需要对现有插件做出改动,才能确保在新版Firefox中可继续正常运行。首先自9月22日Firefox 41发布之日起,所有插件都将需要经过验证,由Mozilla签署。

当前,Mozilla是采用黑名单的方式来禁用一些恶意插件,不过似乎收效不大,所以Mozilla做出了这样的规定,要求所有开发者提交其插件,由Mozilla进行审核之后才能发布。

新的WebExtension API兼容Blink,这样一来,开发者要在Chrome、Opera、Firefox和Edge浏览器之间进行插件的移植,所做的改动会少很多。

将来的Firefox 43预计就会采用新API,发布时间定为12月15日。从这个时间开始,还没有做出改动的插件还能继续使用6个月时间,此后Mozilla就不会再对这些插件做支持了。

Mozilla当然也知道,做出这样的改变可能会伤害到仅为Firefox制作插件的开发者的感情,还要采用新的API,不过Mozilla表示: “最终的结果会是值得的。”这同时也意味着XUL和XPCOM技术的价值不再,Mozilla在未来12-18个月内就会结束对它们的支持。

其实这个变动,无论是对Mozilla,还是对开发者而言都是比较巨大的,对Mozilla而言,这样的迁移肯定需要付出一些代价。但对用户而言无疑是个好事情。这也就意味着Firefox的插件很容易移植到其他浏览器上,对用户的安全保护也会做得更好。

原文链接:,转发请注明来源!
0 0

发表评论

  • 评论2则,共1页,当前第1
    • wisedom

      这。。。好像不太好,一些插件不会去签名的

      0 0 Firefox 40.0 Firefox 40.0 Windows 8.1 x64 Edition Windows 8.1 x64 Edition回复